Browse Source

- added improved message if GNU11 support not detected

development
Andreas Romeyke 8 months ago
parent
commit
1ebe0b54a9
  1. 6
      src/CMakeLists.txt

6
src/CMakeLists.txt

@ -57,7 +57,9 @@ CHECK_C_COMPILER_FLAG("-std=gnu11" COMPILER_SUPPORTS_GNU11)
if(COMPILER_SUPPORTS_GNU11)
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu11")
else()
message(STATUS "Your compiler (${CMAKE_C_COMPILER}) has no gnu11 support. If you are using clang on Apple OS X, please switch to gcc (version > 4.7) which is compliant with the C11 standard.")
message(STATUS "Your compiler (${CMAKE_C_COMPILER}) has no gnu11 support.")
message(STATUS "If you are using clang on Apple OS X, please switch to gcc (version > 4.7) which is compliant with the C11 standard.")
message(STATUS "If you are using MinGW or compile under MS Windows, the code could compile, but without any warranty and without any support!")
endif()
@ -175,4 +177,4 @@ corresponding values more fine granulary. The rulesets are human readable and
could be adapted to own needs.")
set(CPACK_DEBIAN_PACKAGE_SECTION "misc")
set(CPACK_DEBIAN_COMPRESSION_TYPE "xz")
include(CPack)
include(CPack)
Loading…
Cancel
Save